DSC resource does not exist at the Powershell module path

I’m using xHyper-V module and installed with

Find-Module -Name xHyper-V -Repository PSGallery|Install-Module

When I run
it finds it OK:

PS C:\> Get-DscResource -Module xhyper-v

ImplementedAs   Name                      ModuleName                     Version    Properties
-------------   ----                      ----------                     -------    ----------
PowerShell      xVHD                      xHyper-V                 {Name, Path, DependsOn, Ensure...}
PowerShell      xVhdFile                  xHyper-V                 {FileDirectory, VhdPath, CheckSum, DependsOn...}
PowerShell      xVMHyperV                 xHyper-V                 {Name, VhdPath, DependsOn, EnableGuestService...}
PowerShell      xVMSwitch                 xHyper-V                 {Name, Type, AllowManagementOS, BandwidthReserv...

When I run my script, the mof file gets created fine but it can’t find the module with this error:

The PowerShell DSC resource MSFT_xVMHyperV from module  does not exist at the PowerShell module path nor is it registered as
a WMI DSC resource.
    + CategoryInfo          : InvalidOperation: (root/Microsoft/...gurationManager:String) [], CimException
    + FullyQualifiedErrorId : DscResourceNotFound
    + PSComputerName        : lithium

I’ve rebooted my workstation since installing the module but it’s not working. The previous version 3.5 was working, but I uninstalled that and installed the latest. Any ideas?

Updated the server-side module fixed it.