Cannot use Get-Member on SCCM "Get-CMSoftwareUpdate" cmdlet?

I log into my SCCM 2012 R2 Site Server, I run the “Connect via Windows PowerShell” selection on the ribbon dropdown within the SCCM console and I run the following command and I get nothing, it just sits there with a blinking cursor FOREVER.

Get-CMSoftwareUpdate | gm

Is anyone privy to why this is occurring?

I am trying to find out all the parameters I can use with this cmdlet, but I can’t if get-member isn’t working with it. I can use get-member on other SCCM cmdlets, just not the one I need it to.


I’m not sure what’s causing that, but Get-Member isn’t used to show you what parameters you can use. For that, you’d run:

Get-Command Get-CMSoftwareUpdate -Syntax

I meant properties, not parameters.

I want to see all the “properties” that get-cmsoftwareupdate can work with, not parameters.


Try selecting a specific update, and then pipe it to Get-Member, or do Get-CMSoftwareUpdate | Select-Object -First 1 | Get-Member. If you haven’t specified an update, it’s likely trying to enumerate all of the updates you’ve sync’d.


Yep that was it Will.

Thanks man

Anytime! :slight_smile: