WinRM and exchange behaving oddly


I have a utility which does a Search-mailbox on our exchange servers that has worked fine until last week. I am now getting the following error when issuing the search-mailbox cmdlet:

Processing data for a remote command failed with the following error message: The client cannot connect to the destination specified in the request. Verify that the service on the 
destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the 
destination is the WinRM service, run the following command on the destination to analyze and configure the WinRM service: "winrm quickconfig". For more information, see the 
about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OperationStopped: ({server}:String) [], PSRemotingTransportException
    + FullyQualifiedErrorId : JobFailure
    + PSComputerName        : {server}

However, I can happily do an invoke-command to that same server and run other cmdlets such as get-process so its not winrm that seems at fault. I have restarted winrm and the server and I have upped the winrm connection count and memory size (although everything used to be fine asis). So what would cause winrm to be ‘half’ working? I note that the search-mailbox command runs for about 30 seconds before getting this error.


I don’t think WinRM is “half working;” I’m not even sure how you’d make that happen :). I suspect that something’s gone wrong with Search-Mailbox, although without being ON the machine and, for example, running a packet capture, it’s kind of hard to guess what it might be.

Funnily enough its not just search-mailbox - I tried a restart-service via invoke-command and it failed with the same message. Its also happening on all our Exchange servers. It appears to have started happening after the latest patches for Exchange 2010 were installed.

Oh great. Now I get the exact same error running the search-mailbox command in the exchange shell on the exchange server :frowning:

David. I came across this post. Funnily enough, I have come across the same issue with all our Exchange 2010 Servers since Windows Updates done 3-4 weeks ago. When we run the Search-Mailbox command from the Exchange Management Console, we get the same error. Did you find a resolution to the issue or still searching for a fix?

Glad its not just me! We have an open case with Microsoft support. I will let you know the outcome.
David Z

Thanks for the reply. Let me know how you get on with Microsoft Support.

I have been digging through IIS logs and WinRM error messages to find anything. I am almost convinced it is something IIS related to the Powershell Virtual Directory.

There is a work around I have found. While you cannot run certain commands from the Exchange Management Console Shell (e.g. search-mailbox), I have found you can run the command from the “Admin Tools > Windows Powershell Modules”. Be interested if you can find you can run the the commands ok from here as well.


Hi David,

Any luck with Microsoft Support on this one?


Still with microsoft support. Still getting random errors. Sometimes works , sometimes doesnt.
Recently Enable-distributionlist has started to fail randomly without errors (even in try-catch).

We think we’ve found what it is. Exchange and dotnet 4.7 don’t like each other. dotnet 4.7 is not that easy to remove but if it is on your exchange servers then get rid of it!