VM sees host but not the other way around


I’m working on a script in my home lab and I need to use Invoke-Command to execute commands on a VM in the workgroup.
I’ve added the destination machine, which is a guest VM, to the trusted host list on the Hyper-V host. Both machines are 2012 R2. I connected the guest into an external VM switch.

When I run Test-Connection on the guest, it returns true, but the host cannot talk to the guest. I’ve been trying to troubleshoot it, but I can’t imagine how is that possible. If the guest can talk to the host, why not the other way around? (There’s another guest VM, which it can talk to.) Anybody has any idea?

Check your Windows Firewall settings on the guest; you might be blocking ICMP traffic, among other things. (The ping rules tend to contain text such as “Echo Request - ICMPv4-In” and “Echo Request - ICMPv6-In”.)

Thanks for the idea, the problem is solved. I just had to enable network sharing and discovery: netsh firewall set service fileandprint enable
I should have thought :slight_smile: