Unable to bind my array as a table in the html tag in powershell

I have following powershell code snippet:

.....

..foreach($artifactsde in $artifactalias){
$global:ss +='<tr><td>{0}</td><td>{1}</td><td>{2}</td></tr>' -f $artifactsde.AID,$artifactsde.Atype,$artifactsde.versaid

}

where my artifactalias in debugger mode is something as shown in below diagram and my $ss is something as shown in another screen shot.
I am trying to form a table with all my contents in artifactalias and bind it with html tag. if i bind the $ss with my html tag I get System.Object[] as the output on my html content. what wrong am i doing??

I am not getting option to insert image
artifactalias>
@{Atype=System.Object[]; versaid=System.Object[]; AID=System.Object[]}

$ss response:
<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd”> <html xmlns=“http://www.w3.org/1999/xhtml”> <head> <title>HTML TABLE</title> </head><body> <colgroup><col/
><col/><col/></colgroup>

AID Atype versaid
System.Object[] System.Object[] System.Object[]
</body></html> <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1
.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd”> <html xmlns=“http://www.w3.org/1999/xhtml”> <head> <title>HTML TABLE</title> </head><body>
</body></html> System.Object[]S
ystem.Object[]System.Object[] System.Object[]System.Object[]System.Object[] </t
d> System.Object[]System.Object[]System.Object[]

Please read this guide on posting code. As it stands I can’t make out what your code is.