The resource URI is missing or it has an incorrect format

I need to manually configure PS remoting in Core edition, and the following is driving me crazy…

This works fine (in PS Core):

Get-WSManInstance -ResourceURI winrm/config/listener -SelectorSet @{Address="*";Transport="http"}

cfg : http://schemas.microsoft.com/wbem/wsman/1/config/listener
xsi : http://www.w3.org/2001/XMLSchema-instance
lang : en-US
Address : *
Transport : HTTP
Port : 5985
Hostname :
Enabled : true
URLPrefix : wsman
CertificateThumbprint :
ListeningOn : {127.0.0.1, 192.168.8.100, ::1, fe80::3c63:2cb6:6842:92be%3}

But when I try to edit configuration (in PS Core):

Set-WSManInstance -ResourceURI winrm/config/listener -SelectorSet @{address="*";transport="http"} -ValueSet @{Enabled="false"}

I get this bogus error:

Set-WSManInstance: The WS-Management service cannot process the request. The resource URI is missing or it has an incorrect format. Check the documentation or use the following command for information on how to construct a resource URI: “winrm help uris”.

What exactly is meant by “The resource URI is missing or it has an incorrect format”?
URI is just fine and is obviously not missing.

In Windows PowerShell both of these commands work normal:

Get-WSManInstance -ResourceURI winrm/config/listener -SelectorSet @{Address="*";Transport="http"}

Same working output as in previous example.

Set-WSManInstance -ResourceURI winrm/config/listener -SelectorSet @{address="*";transport="http"} -ValueSet @{Enabled="false"}

Working output as in first example.

Obviously there is something wrong with PS Core, anyone had this issue?

I figured out a workaround (but not solution) for this problem is to use New-Item, but my question of why Set-WSManInstance does not work remains.

A workaround that works:

New-Item -Path WSMan:\localhost\Listener -Address * -Transport HTTPS -Enabled $true

Why Set-WSManInstance does not work?