Single quote in a string

Hi Everyone

I am dealing with displayName attribute in AD. I am dumping these names into an Oracle table. Some names have a single quote in them. For example - Jerry O’Brian

In my script I am using single quotes around the variable. Like this - ‘$displayName’
The script throws an exception when it finds that name. So I get all names into the table except this.

I tried using double quotes, two single quotes, tried different escape characters. Nothing worked. Any ideas?

I am hoping someone can help.


What command are you running that returns the error? What is the content of the error message? There’s no particular issue with having a single quote in a string variable, but maybe the particular command you’re running is balking at it, and you might need to do some error handling. Or maybe the database field has a problem with it?


Single quotas outside variable will convert the variable name into a String and not how double quotas shows you what’s inside the variable.

$variable = ‘text’
“$varible” returns: text
‘$variable’ returns: $variable