Nodes mistaking GUID for computer name

Hi All
I am trying to set up a HTTPS Pull Server and I am having problems getting the clients to recognize that a mof is valid.

On the HTTPS Pull Server, the MOF is located at “\\c$\Program Files\WindowsPowerShell\DscService\Configuration” and is called “6247b8fa-d271-4c8b-8c04-e80ae7ad2008.mof”

On the Clients, then LCM has the following configurationID: “6247b8fa-d271-4c8b-8c04-e80ae7ad2008”

When I run "Start-DscConfiguration -Path “\\c$\Program Files\WindowsPowerShell\DscService\Configuration” -wait -verbose -force, I get the following error:

VERBOSE: Perform operation ‘Invoke CimMethod’ with following parameters, ‘‘methodName’ = SendConfigurationApply,‘className’ = MSFT_DSCLocalConfigurationManager,‘namespaceName’ =
WinRM cannot process the request. The following error occurred while using Kerberos authentication: Cannot find the computer 6247b8fa-d271-4c8b-8c04-e80ae7ad2008. Verify that the computer exists on the
network and that the name provided is spelled correctly.
+ CategoryInfo : NotSpecified: (root/Microsoft/…gurationManager:String) [], CimException
+ FullyQualifiedErrorId : HRESULT 0x80070035
+ PSComputerName : 6247b8fa-d271-4c8b-8c04-e80ae7ad2008

VERBOSE: Operation ‘Invoke CimMethod’ complete.

Does anyone know why the client is looking for a computer called “6247b8fa-d271-4c8b-8c04-e80ae7ad2008” and not applying the configuration to itself?

I’ve got past this error but now have a second :slight_smile:

It seems that my nodes are all expecting a different checksum when I run “update-dscconfiguration”:

VERBOSE: [WDLEGACYWEB02DE]: [] Executing Get-Action with configuration 's checksum failed.
Please check the availability of pull server.

I am generating the mof and checksum by doing the following:

$source = “\\mofs\iisnodes\iisnodes.mof”
$dest = “\\c$\Program Files\WindowsPowerShell\DscService\Configuration$guid.mof”
Copy-Item -Path $source -Destination $dest
New-DSCChecksum $dest

So, if the mof & checksum should be the smae for all nodes, how come each node is expecting a different checksum?

problem solved. I had to upade to the latest WMF:

*i feel like this forum is one giant echo chamber :slight_smile: