Exchange Remoting

by at 2013-01-25 08:03:15

Hi all,

Looking to remove the PSLanguageMode restriction on our Exchange 2010 server.

I can remote in to http://server/powershell without issue and get RestrictedLanguage. I followed Shay Levy’s walk through here. I can now connect to either http://server/powershell or http://server/exadmin.

Everything appears to be set to FullLanguage for exadmin, yet I am still getting sent to a runspace in RestrictedLanguage languagemode. Any suggestions?

edit - Addional details:
]Ran the script essentially as is. Also tried the some steps manually (i.e. copy web.config, change RestrictedLanguage to FullLanguage).[/]
]Application Settings for /PowerShell show PSLanguageMode RestrictedLanguage. Application Settings for /exadmin show PSLanguageMode FullLanguage[/]
]I have cycled the exadmin application pool with no effect[/]
]This happens on two of our CAS servers[/]
]This happens when I enter a PSSession from a remote system or locally on the Exchange Server[/]
]I have not cycled IIS - will be trying this later tonight…[/*][/list]

by DonJ at 2013-01-25 08:39:33
You can’t modify some session configurations, especially ones run by a custom host endpoint. If Shay’s tutorial was intended to do what you’re after, have you contacted him to see why it isn’t working?
by at 2013-01-25 08:43:53
Hello Don,

Pinged him with a comment on that blog post, it sounds like at least one other person has seen similar behavior, but others work without issue.
by DonJ at 2013-01-25 08:54:06
Ugh. Those are the worst.