Accessing SFTP path with Special characters

I am trying to access an SFTP URL using the open command. using the open command I am able to access other urls with no special characters in the password.
My doubt is that it is due to the “$” in the password.

working connection
open sftp://USERID:PASSWORD@SERVERURL -hostkey=“ssh-dss 4004 X:X:X:X:X:X:X:X:X:X:X:X:X:X:X:X”

the issue with the new connection with a special character in the password
open sftp://USERID:P$WORD@SERVERURL -hostkey=“ssh-dss 4004 X:X:X:X:X:X:X:X:X:X:X:X:X:X:X:X”

I tried options with multiple options like password inside a variable $pass=‘P$WORD’ but still I am not able to connect.

Any suggestions?

vicks,
Welcome to the forum. :wave:t4:

May I ask if the password has to have a dollar sign in it? :wink:

Have you tried:

open sftp://USERID:P%24WORD@SERVERURL -hostkey=“ssh-dss 4004 X:X:X:X:X:X:X:X:X:X:X:X:X:X:X:X”

just tried it’s not working. :frowning:

This is where I got that info … maybe the actual link will help.

Is it sporting ambition or do you want to get the job done? If it’s the latter one you may consider changing the password to something less troublesome yet secure and move one with your life. The quality of a good password does not come from the specific characters you use, it basically comes from the length (amount of distinct characters) of it. :wink: