Access Denied to Nano Server

Hi I have a Dell Poweredge 2950 Server running Windows Server Core 2008R2 x64 with the HYper-V Role installed. I also have an identical machine running VMware 5.5.

I have on the VMware system a full Domain system running. I use a Win 7 pro x32 client running the HYPER-V feature which accesses the Hyper-V system.

I have 2x VM’s running on the Hyper-V system a; Backup Server (2008R2)and a SQL 2014 Server (2012R2). I downloaded and setup the Nano Server VHD from Microsoft as a virtual Machine. I use the win 7 pro VM machine to run Powershell which I have updated to V5; I have tried to access the Nano Server by using Enter-PSSession. I use the IP address of the VM Machine and used the administrator account of the Nano Server along with a password I have set for it’s local account. Powershell keeps reporting back ‘Access Denied’.

I have all the relevant Firewall ports open as well as the WinRM service setup correctly including any ‘Trusted Hosts’ that are required. I can access all other machines in the domain via PS remoting capabilities. I also use a workgroup laptop that has all the relevant features setup and this too can access all the domain machines; again this suffers from the ‘Access Denied’ error.

Is there a way to do a trace with the error messages to see what/where the actual problem lies?

Could someone point me in the right direction; may be I have missed something. The Microsoft Nano VHD still has the Pacific time; and is still a workgroup machine. I live in the UK and would if possible be able to adjust the time at least and add packages or join a domain later; else scrap it and see if I can get Server 2016 installed and create my own Nano to play with and document the whole process to set it up.

By the way Don J, if you read this; Love the Powershell book (v2) you wrote and watched loads of your video’s on Youtube - Get hold of J Snover and break his keyboard next time (HA! HA!). Looking forward to the Next Powershell book to. (I have also read the SQL book - going to go back; re-read and do the labs this time! :-))

It’d be helpful if you could show the actual commands you’re running. Otherwise, I’m probably going to end up suggesting things you’ve already tried and wasting your time ;). For example, you can’t use the default Kerberos protocol; you have to specify Basic authentication, as well as set up TrustedHosts.

Hi Don thanks for the reply. From any of the other machines that I try to access the Nano Server from I use the standard Enter-PSSession Cmdlet. ‘Enter-PSSession -cred\administrator’ I enter the password for the Nano Server that I setup for it when it was installed and get then get the ‘Access Denied’ message.

I have checked the firewall rules on the Nano they are as expected for the WinRM service. I have ran ‘Test-WSman’ and get the following output:

wsmid :
ProtocolVersion :
ProductVendor : Microsoft Corporation
ProductVersion : OS: 0.0.0 SP: 0.0 Stack: 3.0

Trustedhosts config on my clients are:

PS C:\WINDOWS\system32> Get-item wsman:\localhost\client\trustedhosts

WSManConfig: Microsoft.WSMan.Management\WSMan::localhost\Client

Type Name SourceOfValue Value

System.String TrustedHosts *

PS C:\WINDOWS\system32>

I hope this helps in some small way. As I cannot remotely access the Nano Server I cannot check any other settings apart from the firewallconfig on the Machine.

This has confused me as the other video’s I have watched shows the remote connection working.

Best regards
and Many thanks again.


Enter-PSSession -cred\administrator

Isn’t quite enough. You need to specify Basic authentication on the command. It’s trying to use Kerberos, which won’t work. Nano -should- have Basic enabled by default for this exact reason. Additionally, don’t put the IP address into the credential. That isn’t how those work ;). Just Administrator is fine.

However, keep in mind that for Windows VMs running on a Hyper-V host, with PowerShell v5 on the host, you can do a cool little trick - and this is sort of the intent for setting up Nano. Instead of -ComputerName, specify -VMName. Again, Enter-PSSession needs to run on the HOST server, not your client. This makes the connection via the VM integrations instead of WinRM. See

Don this is another thing I thought of last night. I’m using Server Core 2008 R2 and its running powershell v2. I did download v5, unblocked the file in it’s properties using a win 7 client vm and copied it to the Server core root c:.

I then remote desktop’d to the machine, ran the MSU and rebooted the host are was required. When it had rebooted I ran ‘Powershell.exe’, checked the $PSVersiontable and it still showed v2.0!

Would I have to look elsewhere for the updated version? I checked ‘Program Files’ and the (x86) version, no sign of the powershell folders.

Also V5 should be compatible with Server Core 2008r2 shouldn’t it?


I’d start a separate thread if you want to discuss a new topic. But, PowerShell installs to System32, not Program Files. I don’t recall how far back you can install v5.

Hi, to get my Hyper-V Server Powershell upgraded, I had to install .Net 3.51, 4.0 then upgrade to 4.5, but not before installing v2.0! I first tried 3.0, this went ok eventually, then added in v5.0.

I tried the VMname but had an error here also; it basically said there was no VM with the name I provided, the name was correct as I got the info from Get-VM which showed me the VM’s on my Hyper-V server.

I tried another VM that was listed; this too reported the same error! So I tried to stop/start the Nano by it’s name and my SQL vm also and they stopped and started with no issues. Just have a problem with remoting from the host. I can remote to my SQL server from any of the two workgroup laptops and also any of the domain joined machines! Nano is still a problem all over.

Now I am totally stumped!